File chromium-plugin-widevinecdm.spec of Package chromium-plugin-widevinecdm
62
1
#
2
# spec file for package chromium-plugin-widevinecdm
3
#
4
# Copyright (c) 2016 Packman Team <packman@links2linux.de>
5
#
6
# All modifications and additions to the file contributed by third parties
7
# remain the property of their copyright owners, unless otherwise agreed
8
# upon. The license for this file, and modifications and additions to the
9
# file, is the same license as for the pristine package itself (unless the
10
# license for the pristine package is not an Open Source License, in which
11
# case the license is the MIT License). An "Open Source License" is a
12
# license that conforms to the Open Source Definition (Version 1.9)
13
# published by the Open Source Initiative.
14
15
# Please submit bugfixes or comments via https://bugs.links2linux.org/
16
#
17
18
19
# To find out the real version of Widevine CDM, do something like this.
20
# d="$(mktemp -d)" && rpm2cpio *.rpm|cpio -idmD"$d" && grep \"version\" "$d"/opt/google/chrome/WidevineCdm/manifest.json | sed 's/[a-z":,[:space:]]*//g' && rm -r "$d"
21
%define _chrome_version 134.0.6998.165
22
Name: chromium-plugin-widevinecdm
23
Version: 4.10.2891.0
24
Release: 0
25
Summary: Chromium Widevine CDM plugin
26
License: NonFree
27
URL: https://google.com/chrome
28
Source: https://dl.google.com/linux/chrome/rpm/stable/x86_64/google-chrome-stable-%{_chrome_version}-1.x86_64.rpm
29
BuildRequires: cpio
30
BuildRequires: rpm
31
Requires: chromium-browser
32
# chromium-widevinecdm-plugin was last used in openSUSE Leap 42.1.
33
Provides: chromium-widevinecdm-plugin = 22.%{version}
34
Obsoletes: chromium-widevinecdm-plugin < 22.%{version}
35
ExclusiveArch: x86_64
36
37
%description
38
Official Widevine CDM plugin for Google's FOSS browser Chromium.
39
40
%prep
41
%setup -q -c -T
42
rpm2cpio %{SOURCE0} | cpio -idmv
43
44
%build
45
# Nothing to build.
46
47
%install
48
mkdir -p %{buildroot}%{_libdir}/chromium/
49
cp -r opt/google/chrome/WidevineCdm %{buildroot}%{_libdir}/chromium/
50
51
%files
52
%license opt/google/chrome/WidevineCdm/LICENSE
53
%dir %{_libdir}/chromium
54
%dir %{_libdir}/chromium/WidevineCdm
55
%dir %{_libdir}/chromium/WidevineCdm/_platform_specific
56
%dir %{_libdir}/chromium/WidevineCdm/_platform_specific/linux_x64
57
%{_libdir}/chromium/WidevineCdm/LICENSE
58
%{_libdir}/chromium/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
59
%{_libdir}/chromium/WidevineCdm/manifest.json
60
61
%changelog
62